PDAce   PDAce   PDAce
 
סקירות ומדריכים
חפש
 
דף הבית
סקירות ומדריכים
השוואת מכשירים
מילון מונחים
תוכנות מומלצות
קישורים לאתרים נבחרים
הוראות שימוש באתר
מי אנחנו
טאגליינס
 
החיים מבעד ל-PDA
PDAce - Stories העינויים שעובר גאדג"טיר ממוצע
או: בדרך אל האושר

 
 
טאגליינס

תיקון מסד נתונים פגום בתוכנות PIM

 
מאת: עמית שני
מה לעשות על מנת לשחזר מסדי נתונים פגומים באפליקציות PIM (יומן, אנשי קשר, מזכרים, משימות), כאשר הנתונים המעודכנים נמצאים בפאלם בלבד ולא ניתנים לסנכרון.

הסימפטום:

הפאלם מראה את כל הנתונים באופן תקין אבל כאשר מנסים לסנכרן, הסנכרון נתקע על אחת מאפליקציות ה PIM.

הבעיה נגרמת כאשר בסיס הנתונים של האפליקציה התקועה פגום. יתכן והדבר נגרם עקב רשומה אחת מקולקלת או שגיאה כללית בבסיס הנתונים.

במידה והתקלה היא רק בלוח השנה (יומן), כדאי לנסות להריץ את התוכנה dbScan לפני כן ולבדוק אם היא מתקנת את התקלה.
אם אפשר להסתדר רק עם מה שעל הדסקטופ והנתונים שבתוכנת הדסקטופ מעודכנים מספיק או שאין הבדל גדול בין הנתונים בדסקטופ לבין הנתונים שעל גבי הפאלם. במקרה כזה, אפשר להשתמש במדריך הבא לתיקון הנתונים בתוכנת פאלם דסקטופ ואז לסנכרן אותם חזרה למכשיר.

המדריך הזה הוא לשימוש רק במקרה והעותק העדכני ביותר נמצא על הפאלם בלבד.

איך מתקנים:

הקדמה:

תהליך התיקון, בקצרה, הוא בעצם להעביר את כל הנתונים של האפליקציה הבעייתית לפאלם אחר. בצורה כזו, יועברו הנתונים מהפאלם הראשי לפאלם הזמני בצורה תקינה. לאחר מכן ייבוא הנתונים מהפאלם הזמני לפאלם הראשי.
כל פעולות הסנכרון במדריך זה מתייחסות לסנכרון מול פאלם-דסקטופ. לא מומלץ להשתמש באווטלוק לצורך שחזור בסיס נתונים פגום בשל הבעייתיות שבסנכרון שני מכשירי פאלם לאותה תוכנה וכן בשל האפשרות לאיבוד נתונים בשלב ההמרה מאווטלוק לפאלם-דסקטופ ולהפך.
במדריך זה, נתייחס לפאלם ובו הנתונים המלאים שיש לתקן אותם בתור הראשי. הפאלם שבו נשתמש כצינור להעברת המידע לתיקון יקרא הזמני.

המצרכים (בנוסף לפאלם עם בסיס נתונים פגום):

  • מחשב עם תוכנת פאלם-דסקטופ.
  • מכשיר פאלם נוסף, זמני, ללא נתונים כלל (רצוי אחרי Hard-Reset). כדאי מאוד שהמכשיר יהיה מאותו דגם כמו זה הדרוש שחזור. אם אין כזה בנמצא, עדיף למצוא אחד דומה ככל שניתן. תוכנות ה PIM שונות בין הדגמים השונים של פאלם ואם המכשירים אינם זהים, יתכן ויאבד מידע במהלך התהליך.
  • אמצעי סנכרון (כבל, Bluetooth, אינפרא-אדום וכו') עבור שני המכשירים המשתתפים בתהליך.

שלב א - גיבוי:

  1. יש לוודא שישנו גיבוי מלא, עדכני ותקין לכל הנתונים של הפאלם הראשי. תזכורת: סנכרון אינו גיבוי.
  2. במידה והפאלם הזמני מכיל גם הוא נתונים, יש לדאוג לו לגיבוי גם כן.

שלב ב - הכנת הפאלם הזמני:

  1. יש לסנכרן את הפאלם הזמני מול תוכנת פאלם-דסקטופ. חשוב מאוד: לתת לפאלם הזמני שם שונה לחלוטין מהפאלם הראשי, על מנת שלא יהיה בילבול בין השניים. לדוגמה Temp-Palm.
  2. בהנחה שהפאלם הזמני נקי מנתונים (אחרי Hard-Reset) יש להתקין עליו עברית. אפשר להשתמש בגרסת ניסיון של עברית שעובדת רק לכמה ימים שכן בסיום אפשר יהיה להסיר אותה ולמחוק שוב את הפאלם הזמני.
  3. את הנתונים נעביר מהפאלם הראשי לפאלם הזמני ע"י Bluetooth או אינפרא אדום. לכן יש לבחור את אחת השיטות ולוודא בפאלם הזמני שהאפשרות לקבל נתונים בשיטה זו, מופעלת.
  4. במידה ויש חשיבות לחלוקה לקטגוריות של הנתונים הפגומים, יש לפתוח בפאלם הזמני את האפליקציה שאליה נעביר נתונים וליצור בה מערכת קטגוריות זהה לזו שבפאלם הראשי.
  5. בסיום ההכנה רצוי לסנכרן שוב את הפאלם הזמני.

שלב ג - העברת הנתונים:

  1. יש לפתוח בפאלם הראשי את האפליקציה הבעייתית.
  2. העברת הנתונים נעשית ע"י העברת כל קטגוריה בנפרד. אם חשובה החלוקה לקטגוריות, יש לבחור את אחת הקטגוריות בתצוגת הנתונים. אם החלוקה לקטגוריות אינה משמעותית, אפשר לבצע את הפעולה על הקטגוריה שמציגה את כל הנתונים (All).
  3. לפתוח את התפריט ולבחור Send Category להעברת הנתונים לפאלם הזמני ע"י Bluetooth או Beam Category להעברה באמצעות אינפרא-אדום. אם נבחרה האפשרות Send, יש לבחור לאחר מכן Bluetooth ולאחר מכן את הפאלם הזמני שיופיע ברשימת המכשירים הזמינים. אם נבחרה Beam, יש למקם את המכשירים אחד מול השני ולהמתין לסוף ההעברה.
  4. בסוף ההעברה יפתח חלון בפאלם הזמני שישאל לאיזו קטגוריה לשייך את הנתונים שהתקבלו. במידה וישנה חשיבות לקטגוריה, יש לבחור את זו המתאימה.
  5. אם הועברה רק קטגוריה אחת יש לחזור על התהליך עבור כל שאר הקטגוריות. לא לשכוח בעת קבלת הנתונים בפאלם הזמני, לסמן את קטגורית היעד.

שלב ד - ייצוא הנתונים:

  1. יש לסנכרן את הפאלם הזמני. כל הנתונים שבו אמורים לעבור לפאלם-דסקטופ.
  2. יש לוודא שהתוכנה מציגה רק את הנתונים של המכשיר הזמני ולא את אלו של הראשי. ניתן לעבור בין המשתמשים ע"י שימוש בתיבת הבחירה Users שנמצאת בפינה הימינית-עליונה של התוכנה.
  3. יש להציג את הנתונים החסויים ע"י שימוש ב View > Show Private Records.
  4. יש לבחור את כל הנתונים המוצגים ע"י Ctrl+A או Edit > Select All.
  5. לייצוא הנתונים שנבחרו (כולם) יש לבחור בפקודה File > Export ולבחור שם לקובץ הנתונים שיוצאו.

שלב ה - ייבוא הנתונים:

  1. בתוכנת פאלם-דסקטופ לעבור למשתמש של הפאלם הראשי. ולפתוח את האפליקציה הבעייתית.
  2. יש להציג את הנתונים החסויים ע"י שימוש ב View > Show Private Records.
  3. יש לבחור את כל הנתונים המוצגים ע"י Ctrl+A או Edit > Select All.
  4. לוודא שאכן מוצגים הנתונים של הפאלם הראשי ולא הזמני, ולמחוק את כל הנתונים שנבחרו ע"י לחיצה על מקש Del או Edit > Delete. יש לסמן V עבור שמירת הנתונים בארכיב ולאשר את המחיקה.
  5. בשלב זה, לא אמורים להיות נתונים באפליקציה הבעייתית של הפאלם הראשי בפאלם-דסקטופ.
  6. לייבא את הנתונים שנשמרו ע"י בחירת File > Import ולהפנות את התוכנה לקובץ שיוצא בשלב הקודם.
  7. בשלב זה אמורים להופיע כל הנתונים שיובאו מהפאלם הזמני.
  8. לשמור את הנתונים ע"י File > Save All ולצאת מפאלם-דסקטופ.

שלב אחרון - סנכרון:

  1. ללחוץ עם הכפתור הימני של העכבר על הסמל של Hotsync בשורת המשימות ולבחור Custom.
  2. יש לוודא שבשורה העליונה מופיע שם המשתמש של הפאלם הראשי.
  3. לבחור את האפליקציה הבעייתית וללחוץ Change.
  4. לסמן את האפשרות: Desktop Overwrites Handheld. וללחוץ OK.
  5. ללחוץ Done.
  6. לסנכרן את הפאלם הראשי ולקוות לטוב.

בהצלחה
 
5-Dec-2006