PDAce   PDAce   PDAce
 
סקירות ומדריכים
חפש
 
דף הבית
סקירות ומדריכים
השוואת מכשירים
מילון מונחים
תוכנות מומלצות
קישורים לאתרים נבחרים
הוראות שימוש באתר
מי אנחנו
טאגליינס
 
החיים מבעד ל-PDA
PDAce - Stories מניחים תפילין בסופר
או: איך להנות מכל העולמות

 
 
טאגליינס

Resco File Explorer 2005

 
מאת: רענן תמם
מדריך מלא לתוכנה Resco File Explorer 2005

1. הקדמה:

במחשבי כף היד מסוג פוקט ,PC קיים סייר בסיסי כחלק ממערכת ההפעלה המותקנת במכשיר. סייר הקבצים המובנה תוכנן לענות על צורכי המשתמשים במחשבי הפוקט כאשר מערכת ההפעלה הייתה בשלביה הראשונים ותוכננה לשמש כ-Outlook נייד בתוספת יישומים ולא כמחשב לכל דבר. אך בקנה אחד עם התקדמות מערכת ההפעלה והתרבות מספר היישומים המתאימים לה עלה, בקרב המשתמשים, הצורך בסייר קבצים נח יותר ובעל אפשרויות רבות יותר ממה שהציע עד כה סייר הקבצים המובנה. כאן בית התוכנה Resco נכנס לתמונה ויצר את Resco Explorer 2005, סייר קבצים שמביא למחשב הפוקט יכולות הדומות למה שמציע סייר הקבצים במחשב ה-PC.

Resco Explorer 2005 נותן מענה לדרישותיהם של משתמשים "כבדים" (Power Users) מחד ושל משתמשים רגילים מאידך, ע"י ממשק הדומה לסייר הקבצים במחשב ה-PC ומתן כלים מגוונים. הכלים מאפשרים הצפנת קבצים, תמיכה וכיווץ בפורמט ZIP, חיפוש קבצים במערכת סיור בכונן של מחשב ברשת פנימית, עורך רג'יסטרי, לקוח FTP המאפשר גישה לקבצים על שרת FTP, העברת קבצים למחשב אחר תוך שימוש בצורות חיבור שונות (IR, BT וכדומה), תוספת של "סל מחזור" במערכת ובנוסף לכל אלו גם תוסף למסך ה-TODAY המציג מצב הסוללה הזיכרון וקיצורי דרך. כל אלו הופכים את התוכנה לכלי חשוב בכל מחשב כף-יד.

הערה:מטעמי נוחות, מסמך זה נכתב בלשון זכר אך מתייחס לנשים וגברים כאחד.

1.1 תהליך ההתקנה והרישום:

את קובץ ההתקנה ניתן להשיג מאתר היצרן ולהשתמש בגרסת הניסיון, המתפקדת באופן מלא, למשך 60 יום. ההתקנה, בדומה לרב התוכנות למערכת ה-WM, מתבצעת דרך מחשב ה-PC ושימוש ב-ActiveSync. במקרה של תוכנה זו ההתקנה על ה-PC חשובה היות ובתהליך ההתקנה ניתן להתקין על ה-PC תוספים אשר מקנים עבודה גמישה יותר מול הסייר של Resco.

1.2 תהליך ההתקנה:

הפעלת קובץ ההתקנה, על-גבי ה-PC, תביא לחלון בו תנאי הרישיון וההסכם. לחיצה על "אני מסכים" תביא לשלב שבו יש לבחור אילו חלקים של התוכנה יותקנו למכשיר הפוקט או ל-PC. החלקים שניתנים לבחירה הם:

במחשב כף-היד:
  • Resco File Explorer 2005 for PocketPC – התקנת הסייר של Resco למערכת הפוקט.
  • Registry Add-in for Resco Explorer – התקנת תוסף עריכת הרג'יסטרי.
  • FTP Add-in for Resco Explorer – התקנת תוסף ה"לקוח" בפרוטוקול FTP.
  • Resco Today Plugin – התקנת התוסף של Resco למסך ה-Today.

במחשב ה-PC: Desktop Shell Extension)) – תוספים ל-PC המקנים לו יכולת לטפל בקבצים שהוצפנו ע"י התוכנה במחשב כף-היד ותמיכה בהעברת קבצים למחשב כף היד ביתר קלות:

  • Cryptographic Extension – תמיכה בהצפנה ופענוח קבצים בפורמט התואם למחשב כף-היד.
  • SendTo Extension – תמיכה בהעברת קבצים ובחירת מיקומם במחשב כף-היד.
לחיצה על "Install" תביא להתקנת התוכנה ותוספיה שנבחרו, על הפוקט ועל מחשב ה-PC. במידה וכבר מותקנת גרסה ישנה של התוכנה תעלה הודעה המבקשת אישור לשדרוג ושכתוב הגרסה הקודמת לגרסה החדשה.
כמו בכל התקנה גם כאן תעלה הודעה להגדרת מיקום ההתקנה במכשיר. לעניות דעתי, תוכנה שכזו חייבת להיות חלק בלתי נפרד מהמכשיר ולכן אני ממליץ על התקנה במיקום ברירת המחדל. אם יש למשתמש העדפה אחרת אזי עליו להגדיר את המיקום אליו התוכנה תותקן.
בתום ההתקנה יופיע על גבי הפוקט, מסך ובו הסברים על הכפתורים בסרגלים העיקריים של הסייר (הסברים על כפתורים אלו בהמשך). לחיצה על ה-X בראש המסך תסגור את החלון ותסיים את ההתקנה.

1.3 תהליך הרישום:

תהליך הרישום והרכישה נעשים דרך רשת האינטרנט. לשם כך יש להיכנס לאתר היצרן ולבצע את הרכישה. בתום תהליך הרכישה ישלח, באמצעות הדוא"ל, קוד להפעלת התוכנה המותאם לשם המשתמש. לשם רישום התוכנה יש צורך לבצע את התהליך הבא:

  • פתח את תפריט ה-"File".
  • בחר באפשרות "Registration".
  • תחת ה-"Owner" יופיע שם המשתמש בהתאם למה שמוגדר בסעיף "בעלים" בהגדרות המכשיר. במידה והשם אינו זהה לזה שנשלח ל-Resco למטרת קבלת "קוד הרישום" יש צורך לשנות את שם המשתמש בהגדרות המכשיר. לשם כך יש להיכנס לתפריט ה"התחל", "הגדרות" ו"פרטי בעל המכשיר". שם יש להקליד את שם המשתמש באופן מדויק.
  • את קוד הרישום יש להקליד בתיבת ה-"Code".
  • לחץ על "OK".

תהליך הרישום נכשל?
נסה לבצע את התהליך בשנית תוך שימת לב לדברים הבאים:

  • לשם הקלדת נתוני המשתמש והסיסמה, השתמש במקלדת המובנית במכשיר ולא במקלדות של חברות צד שלישי.
  • הקלד את שם ה"בעלים" בדיוק כפי שנשלח ל-Resco. שדה זה הינו תלוי רישיות.
  • המנע משימוש מיותר של רווחים.
במידה ובעיית הרישום נמשכת פנה למחלקת התמיכה בדוא"ל: products@resco-net.com.

2 הכרת התוכנה

סעיף זה יתמקד בעיקר בתכונותיו העיקריות של הסייר והסברים על האפשרויות הניתנות למימוש במסך הראשי של התוכנה כגון: תיאור הכפתורים, הסרגלים והתפריטים הניתנים לשימוש במסך הראשי של התוכנה.

2.1 סרגל הכלים הראשי

ממוקם בתחתית המסך ומכיל מספר פעולות עיקריות ואת תפריטי התוכנה.

2.1.1 תפריט ה-"File"

  • New Folder – יצירת תיקייה חדשה בתיקייה הנוכחית.
  • Receive – קבלת קובץ ב-IR (אינפרא אדום). אפשרות זו מיועדת לשימוש כאשר המשתמש מעדיף שה-IR יהיה כבוי בדרך-כלל.
  • Run – הפעלת קובץ EXE שנמצא במערכת.
  • Options – כניסה להגדרות התוכנה.
  • System Info – צפייה במידע כללי על מחשב כך-היד כגון: מצב סוללה וזיכרון.
  • Registration – רישום התוכנה והכנסת קוד ההפעלה.
  • Favorites – מעבר מהיר לאחת מתיקיות המועדפים או שינוי הרשימה של תיקיות אלו.
  • About – דף ה"אודות". הצגת מספר הגרסה וקישורים לאתר היצרן והתמיכה.

2.1.2 תפריט ה-"Edit"

  • Paste – הדבקת קובץ שהועתק או נגזר לתיקיה הנוכחית.
  • Paste Shortcut – יצירת קיצור דרך, בתיקיה הנוכחית, לקובץ שהועתק לזיכרון.
  • Select All – בחירת כל הקבצים והתיקיות שבתיקייה הנוכחית.
  • Invert Selection – החלפה בין הקבצים שנבחרו באלו שלא על-מנת לבצע בהם פעולות.
  • Drag n' Drop Mode – מצב גרירה ועזיבה. בחירה באפשרות זו תביא למצב בו גרירת הסטיילוס על קובץ תגרור את הקובץ למקום הרצוי. ללא סימון סעיף זה תבוצע בחירה של כל הקבצים והתיקיות בעת גרירת הסטיילוס אליהם.
  • Single/Multi Selection – בחירה של קובץ או מספר קבצים. סימון אפשרות זו יאפשר מצב של בחירת מספר קבצים באופן סלקטיבי (בדומה לבחירה עם מקש ה-Ctrl ב-PC) ע"י לחיצה בודדת על כל קובץ. ללא סימון האפשרות, לחיצה על קובץ תניב את הפעלתו או הצגתו, בהתאם להגדרות.
  • Find – חיפוש קבצים בהתאם להגדרות האישיות.

2.1.3 תפריט ה-"View"

  • Show Folder Bar – הצג את סרגל התיקיות. הסרגל יופיע בחלקו העליון של המסך, תחת ה-Program Bar.
  • Show Tree View – הצגת "עץ הקבצים" כחלק מהסייר בהתאם להגדרות החלוקה, אנכית או אופקית.
  • Show Header – פעיל רק במצב "Details View". הצגת כותרת לכל עמודה בסייר כגון: שם הקובץ, גודלו וכד-ומה. לחיצה על שם העמודה יבצע סידור, עולה או יורד, ע"פ הנתונים באותה העמודה.
  • Show Columns – בחירת העמודות שיוצגו במצב "Details View". ניתן לבחור באחת, או יותר, מהאפשרויות הזמינות: שם הקובץ, גודל, סוג ועוד.
  • Large Icons – תצוגת קבצים כאייקונים גדולים.
  • Small Icons – תצוגת קבצים כאייקונים קטנים.
  • List – תצוגת רשימה. (גלילה לצדדים)
  • Details – תצוגת קבצים כולל פרטיהם בהתאם להגדרות. (גלילה אנכית)
  • Arrange Icons – ניתן להציג את האייקונים לפי אחת מהאפשרויות הבאות: סידור לפי שם (By name), לפי גודל קובץ (By size), לפי שעה שנוצר או שונה (By time), לפי סיווג (By attribute) או לפי סוג הקובץ (By type).
  • Auto Arrange – סידור הקבצים באופן אוטומטי.
  • Refresh – רענון המסך. מיועד למקרים בהם עולה הצורך לרענן את התיקייה על מנת לזהות קבצים חדשים שנכנסו אליה אך לא מוצגים. בדומה למקש F5 ב-PC.

2.1.4 כפתורי הסרגל הראשי

בנוסף לתפריטים קיימים בסרגל הראשי גם כמה כפתורים: (הכפתורים ע"פ הסדר משמאל לימין)
  • Advanced Toolbar – הצגה והסרה של סרגל הכלים המתקדם. הסרגל יופיע בצמוד לסרגל הכלים הראשי ומעליו.
  • Up One Level – עבור רמה אחת מעלה בהיררכיית הקבצים.
  • Cut – גזור.
  • Copy – העתק.
  • Paste – הדבק.
  • Delete – מחק.

2.2 סרגל הכלים המתקדם

סרגל הכלים המתקדם מכיל כפתורים אשר מבצעים פעולות אשר ייחודיות ליכולות הסייר. ניתן להגיע בקלות לפעולות הללו ע"י לחיצה ממושכת על קובץ או תיקיה ובחירה באפשרות המתאימה מהתפריט הקופץ. (הכפתורים ע"פ הסדר משמאל לימין)
  • Go to My Device- מעבר מהיר לצפייה בתיקיה הראשית של המכשיר אשר מכילה תחתיה את תוכן המכשיר על כרטיסי הזיכרון וכו.
  • Back – חזרה לתיקיה בה היה המשתמש קודם לכן.
  • Forward – מעבר קדימה לתיקיה ממנה בוצעה פעולת ה-"Back".
  • Properties – הצגת המאפיינים של הקובץ.
  • Find Files – ביצוע חיפוש קבצים או תיקיות במערכת.
  • Encrypt Files – הצפנת קבצים .
  • Compress Files – דחיסת קבצים לפורמט ZIP.
  • Send to – שלח קבצים או תיקיות אל...
  • Network – אפשרויות הרשת, מיפוי כונן או הסרתו.

2.3 הסרגל העליון

ממוקם תחת ה-"Program Bar" ומכיל שני חלקים עיקריים: ה"מועדפים" ו"נתיב הקבצים".

2.3.1 נתיב הקבצים:

מציג הנתיב של התיקייה שתוכנה מוצג כרגע בחלונית התצוגה. לחיצה על "נתיב הקבצים" תביא לפתיחת "עץ קבצים" דרכו ניתן לנווט לתיקיה אחרת בצורה קלה למדי.

2.3.2 המועדפים:

כאן נמצא קיצורי דרך לתיקיות אשר אליהן מבקש המשתמש לגשת לעיתים תכופות. התפריט הקופץ, בהקשה על האייקון, מכיל את רשימת התיקיות אליהן ניתן לגשת במהירות ואת אפשרות שינוי רשימת התיקיות הללו תחת אפשרות ה-"Add/Delete".
  • Add/Delete - באמצעות אפשרות זו ניתן לבצע שינויים ברשימת תיקיות המועדפים שיהיו בתפריט ה"מועדפים".
  • להוספה - בשורת ה-"Folder" ניתן לבחור בתיקיה מתוך "עץ קבצים". לאחר בחירת התיקייה יש ללחוץ על כפתור ה-"Add New".
  • להסרה - בחלקו התחתון של המסך ישנה רשימה המכילה את התיקיות שהוגדרו כ"מועדפות". בחירת התיקייה ולחיצה על ה-X תגרום למחיקת התיקייה מהרשימה.
  • שינוי סדר ה"מועדפים" - בחירת התיקייה ולחיצה על החץ המתאים בסרגל התחתון, תביא לשינוי מקום התיקייה ברשימת המועדפים.
  • לחיצה על "Cancel" תמנע את שמירת השינויים.

2.4 תפריט ה-Popup בלחיצה ארוכה על קובץ או תיקיה.

סייר הקבצים של Resco מכיל בחובו אפשרויות רבות ניתנות לביצוע תוך שימוש בלחיצה ממושכת על קובץ, אחד או יותר, או תיקיות. תפריט ה-Popup מכיל את האפשרויות הבאות:
  • View – פתיחת הקובץ בתוסף צפייה בקבצים המובנה.
  • Open – פתיחת קובץ.
  • Send To - שלח את הקבצים והתיקיות הנבחרות אל אחד מהיעדים הבאים: נמען דוא"ל, מכשיר אחר בעל תקשורת BT, כקיצור דרך לתוסף של Resco במסך ה-Today, מכשיר אחר באמצעות IR או אל אחת מהתיקיות שהוגדרו בתפריט "שלח אל".
  • Copy To - העתקה אל תיקיה הניתנת לבחירה מ"עץ הקבצים".
  • Move To - העברה אל תיקיה הניתנת לבחירה מ"עץ הקבצים".
  • Encryption - תחת סעיף זה ניתן לבחור האם להצפין קובץ או לפענח קובץ שהוצפן קודם לכן תוך שימוש בסייר.
  • Compress - תחת סעיף זה ניתן למצוא אפשרויות בנוגע לכיווץ, פרישה ואפשרויות נוספות הקשורות בקבצים מסוג ZIP.
  • Cut - גזור.
  • Copy - העתק.
  • Duplicate - שכפול קובץ בתוך אותה התיקייה. הקובץ יקבל שם זהה לקובץ המקור בתוספת "Copy of" בתחילתו.
  • Paste - הדבק.
  • Paste Shortcut - הדבק כ"קיצור דרך".
  • Delete - מחק.
  • Rename - שינוי שם.
  • Properties - מאפיינים. הצגת מאפייני הקובץ בדומה לסייר הקבצים במחשב השולחני.

2.5 תפריט ה-Popup בלחיצה ארוכה על "אזור ריק" בתיקיה.

לחיצה ארוכה על אזור ריק בתיקיה במקום פריט ספציפי תקפיץ תפריט הנוגע לתצוגה וסידור האייקונים.
  • Large Icons - הצגת אייקונים גדולים.
  • Small Icons - הצגת אייקונים קטנים.
  • List - תצוגת רשימה, גלילה אופקית.
  • Details - תצוגת פרטים, גלילה אנכית.
  • Arrange Icons - סדר אייקונים ע"פ הבחירה בתת התפריט.
  • Auto Arrange - סדר אייקונים אוטומטית.

3 סייר הקבצים

סייר הקבצים הינו היישום המרכזי אשר סביבו מרוכזים מספר תוספים. סייר הקבצים מאפשר הצגת מערכת הקבצים בצורה גמישה ומותאמת לדרישותיו והעדפותיו של המשתמש וכמו כן מאפשר מספר נכבד ביותר של פעולות בכל הנוגע לניהול, כיווץ, הצפנה, וחיפוש הקבצים. מבנה תצוגת הסייר דומה מאוד לסייר הקבצים במחשב השולחני ומאפשר פעולות דומות. בחלק זה של המדריך יתוארו דרכי הפעולה הניתנות לביצוע למטרת ניהול הקבצים. הגדרות התצוגה מתוארות בחלקן בהסבר על תפריט ה-"View" (סעיף...) ובחלקן בשלב ההגדרות. (סעיף...)



3.1 שימוש בקבצים:

3.1.1 פתיחת קובץ:

פתיחת קובץ מתאפשרת באחת מכמה צורות:
  • לחיצה על קובץ תביא לפתיחתו ע"י היישום אליו הוא משויך.
  • לחיצה ארוכה על הקובץ הנבחר ובחירה באחת מהאפשרויות הבאות:
    • Open – פתיחת הקובץ ע"י היישום אליו הוא משויך.
    • Open With – פתיחת הקובץ ע"י יישום הניתן לבחירה מהרשימה שתפתח.
    • Associate With – שיוך הקובץ ליישום באופן קבוע. לחיצה על הקובץ בפעמים הבאות תביא לפתיחת הקובץ תוך שימוש ביישום שנבחר.

3.1.2 צפייה והצגת קבצים:

סייר הקבצים של Resco מכיל אפשרות מובנית להצגת קבצים מהסוגים הבאים:
  • קבצים המכילים טקסט בפורמט Binary או Hexadecimal.
  • קבצי תמונה בפורמטים: JPG, GIF, BMP או PNG.
  • קבצי HTML ומסמכים בפורמט "טקסט עשיר" (RTF).

בכדי לצפות בקובץ יש לבחור ב-"View" מתוך התפריט הקופץ שצץ בלחיצה ארוכה על הקובץ. תוכנת הצפייה מכילה תפריט שבו ניתן לבחור באיזה אופן יוצג הקובץ (טקסט, תמונה או אחר) ובסרגל התוכנה קיים כפתור לחיפוש טקסט וכפתורי ZOOM לשימוש כאשר מוצגות תמונות.

3.1.3 העתקת קובץ או תיקיה:

  • בחר את הפריט או הפריטים שברצונך להעתיק.
  • "הקפץ" את התפריט על-ידי לחיצה ממושכת על הפריט שנבחר ובחר באפשרות "Copy". (ניתן להשתמש גם בכפתור ה-"Copy" שבסרגל התחתון)
  • גש לתיקיית היעד אליה ברצונך להעתיק את הקבצים.
  • "הקפץ" את התפריט על-ידי לחיצה ממושכת על התיקייה או בתוכה ובחר באפשרות "Paste".

3.1.4 העברת קובץ או תיקיה:

  • בחר את הפריט או הפריטים שברצונך להעביר.
  • "הקפץ" את התפריט על-ידי לחיצה ממושכת על הפריט שנבחר ובחר באפשרות "Cut". (ניתן להשתמש גם בכפתור ה-"Cut" שבסרגל התחתון)
  • גש לתיקיית היעד אליה ברצונך להעתיק את הקבצים.
  • "הקפץ" את התפריט על-ידי לחיצה ממושכת על התיקייה או בתוכה ובחר באפשרות "Paste".

3.1.5 יצירת קיצור דרך:

  • בחר את הפריט או הפריטים להם הינך רוצה ליצור קיצור דרך.
  • "הקפץ" את התפריט על-ידי לחיצה ממושכת על הפריט שנבחר ובחר באפשרות "Copy". (ניתן להשתמש גם בכפתור ה-"Copy" שבסרגל התחתון)
  • גש לתיקיית היעד אשר בה הנך רוצה למקם את קיצור הדרך.
  • "הקפץ" את התפריט על-ידי לחיצה ממושכת על התיקייה או בתוכה ובחר באפשרות "Paste Shortcut".

3.1.6 מחיקת קובץ:

  • בחר את הפריט או הפריטים אשר מיועדים למחיקה.
  • "הקפץ" את התפריט על-ידי לחיצה ממושכת על הפריט שנבחר ובחר באפשרות "Delete". (ניתן להשתמש גם בכפתור ה-"Copy" שבסרגל התחתון)
  • בתיבת האישור שתעלה בחר באפשרות המתאימה לך:
    • Delete – אשר מחיקה של הפריט הנוכחי. (במידה ונבחרו כמה קבצים, למחיקה, בו זמנית תבוא הודעה על כל קובץ בנפרד).
    • Delete All – כל הפריטים שנבחרו ימחקו ללא הודעת אישור פרטנית.
    • Skip – אל תמחק פריט זה. (במידה ונבחרו כמה קבצים, למחיקה, בו זמנית תבוא הודעה על כל פריט בנפרד).
    • Skip All – דלג על כל הקבצים ללא ביצוע מחיקה.
    • Cancel – ביטול פעולת המחיקה.

הקבצים שנמחקו יועברו לסל המחזור וניתן יהיה לשחזרם אלא אם הוגדר למערכת לא להפעיל תמיכה בסל מחזור.

3.1.7 שינוי שם:

  • בחר את הפריט המיועד לשינוי שם.
  • "הקפץ" את התפריט על-ידי לחיצה ממושכת על הפריט שנבחר ובחר באפשרות "Rename".
  • הקלד את השם החדש ולחץ על מקש ה-Enter במקלדת.

3.1.8 יצירת תיקייה חדשה:

  • כנס לתיקיה אשר בתוכה ברצונך ליצור תיקיה חדשה.
  • פתח את תפריט ה-"File".
  • בחר באפשרות "New Folder".
  • הקלד שם לתיקייה החדשה ולחץ על מקש ה-Enter.

3.1.9 בחירת מספר רב של קבצים:

הדבר דומה לבחירה של מספר קבצים באופן סלקטיבי תוך שימוש במקשים Ctrl או Shift במחשב השולחני.
  • פתח את תפריט ה-"Edit".
  • להפעלת מצב "בחירה מרובה" יש לבחור ב-"Single/Multi Selection".
  • בחר את הקבצים והתיקיות על-ידי הקשה עליהן באופן סלקטיבי.

ניתן לבצע תהליך זהה ע"י שימוש במקשי ה-Ctrl או ה-Shift במקלדת הוירטואלית והקשה על הקבצים הנבחרים.

3.2 הצפנת קבצים:

סייר הקבצים של Resco משמש גם כמערכת להצפנת קבצים. בשימוש ברירת המחדל, הצפנת קבצים מבוצעת תוך שימוש באלגוריתמים RC2(40Bit) או DES(56Bit), אשר מובנים במערכת ההפעלה. משתמשים "כבדים", המעוניינים בהגנה גבוהה יותר על קובציהם, יכולים לעשות שימוש באלגוריתמים מתקדמים יותר כגון: RC2(128Bit), RC5(128Bit), 3DES twokey(112Bit) או 3DES(168Bit).

3.2.1 ביצוע תהליך ההצפנה:

  • בחר את הפריט או הפריטים שמיועדים להצפנה.
  • "הקפץ" את התפריט על-ידי לחיצה ממושכת על הפריט שנבחר ובחר באפשרות "Encryption".
  • בחר ב-"Encrypt".
  • אם ברצונך לשנות את אלגוריתם ההצפנה, לחץ על כפתור ה-"Settings".
  • הקלד סיסמה זהה בשתי התיבות. (הסיסמה תוצג כרצף של כוכביות)
  • כברירת מחדל הקובץ המקורי ימחק לאחר ההצפנה כך שיוותר רק הקובץ המוצפן. אם ברצונך להשאיר עותק מהקובץ המקורי הסר את הסימון מ-"Delete Original File".
  • לחץ על "Done"
  • הקובץ יופיע תחת אותה התיקייה בה היה הקובץ המקורי.

3.2.2 פענוח קבצים:

  • בחר את הקובץ המוצפן.
  • הקש את הסיסמה
  • כברירת מחדל, יימחק הקובץ המוצפן לאחר הפענוח. אם ברצונך לשמור עותק ממנו הסר את הסימון מ-"Delete Encrypted File".
  • לחץ על "Done".
  • הקובץ המפוענח יופיע תחת אותה התיקייה בה היה הקובץ המוצפן.

3.3 שימוש בקבצים, בפורמט דחוס, בפורמט ZIP:

בניגוד לסייר הקבצים המובנה, הסייר של Resco מכיל תמיכה מלאה בקבצים בפורמט ZIP. בעזרת הסייר ניתן לדחוס קבצים תוך שימוש בכמה אלגוריתמים, לפרוש קבצים שנדחסו במחשב כף-היד או ב-PC ואף להגן על הקובץ הדחוס בסיסמה. השימוש בפורמט זה הוא, בעיקר, למטרת חסכון במקום ע"י דחיסת קבצים גדולים אך משמש גם ל"איגוד" קבצים או להגנה בסיסית על קבצים בעזרת סיסמה. ללא צל של ספק, תמיכה בפורט ZIP מקנה לסייר של Resco יתרון חשוב ונותנת גמישות רבה למשתמש.

3.3.1 כיווץ ו"איגוד" קבצים:

  • בחר את הפריט או הפריטים אשר ברצונך לאגד ו/או לדחוס.
  • "הקפץ" את התפריט על-ידי לחיצה ממושכת על הפריט שנבחר ובחר באפשרות "Compress"
  • הקלד שם לקובץ ה-ZIP המיועד.
  • בחר את הנתיב והתיקייה אשר בהם ישמר הקובץ.
  • הגדר את צורת ה"שכתוב" הרצויה.
  • הגדר את רמת הדחיסה הרצויה.
  • לחץ על תפריט ה-"Menu" ובחר באפשרות הרצויה:
    • New Folder – צור תיקייה חדשה אשר בה יהיה הקובץ. התיקייה החדשה תהיה במקום שהוגדר בשלב הרביעי.
    • Set Password – ניתן להקצות סיסמה שתידרש בעת ניסיון פתיחת הקובץ בעתיד.
    • Cancel – ביטול הכיווץ.
הגנת הסיסמה לקובץ ZIP נוחה יותר משימוש בהצפנת הקבצים. פתיחת קובץ מוצפן מחייבת פענוח מלא שלו ובתום השימוש הצפנה מחודשת. לקובצי ה-ZIP ניתן להיכנס ללא צורך בפרישה שלהם ולכן לאחר הסגירה הם יישארו מוגנים כפי שהיו. על-אף זאת מנגנון ההצפנה הינו חשוב , ועדיף לשימוש, למי שמחזיק קבצים סודיים וחשוב לו להקשות כמה שרק אפשר על תהליך פתיחתם בידי גורם לא מוסמך.

3.3.2 פרישת קבצים:

  • בחר בקובץ ה-ZIP המיועד לפרישה.
  • "הקפץ" את התפריט על-ידי לחיצה ממושכת על הפריט שנבחר ובחר באפשרות "Extract To" אשר נמצאת תחת "ZIP Archive".
  • בחר בתיקיה אשר אליה יפרש קובץ ה-ZIP. (ליצירת תיקיה יש לבחור ב-"New Folder" אשר נמצאת בתפריט "Menu".
  • הגדר את מצב השכתוב הרצוי.
  • הגדר האם לשמר את מבנה התיקיות מקובץ המקור ע"י השארת הסימון ב-"Restore Folder Structure". הסרת הסימון תביא לפרישת כל הקבצים לתיקיית היעד ללא התחשבות במבנה המקורי.
  • לחץ על "Extract".

3.3.3 העתקת קבצים ותיקיות ל-ZIP קיים:

  • בחר בפריטים אשר הינך מעוניין להוסיף לקובץ ZIP קיים.
  • "הקפץ את התפריט על-ידי לחיצה ארוכה על הפריט שנבחר ובחר באפשרות "Copy".
  • בחר בקובץ ה-ZIP, אשר אליו יועתק הפריט הנבחר, והכנס אל הנתיב המדויק שאליו יועתק הקובץ.
  • "הקפץ" את התפריט ובחר ב-"Paste".

3.3.4 העברת קבצים ותיקיות ל-ZIP קיים:

  • בחר בפריטים אשר הינך מעוניין להעביר לקובץ ZIP קיים.
  • "הקפץ את התפריט על-ידי לחיצה ארוכה על הפריט שנבחר ובחר באפשרות "Cut".
  • בחר בקובץ ה-ZIP, אשר אליו יועתק הפריט הנבחר, והכנס אל הנתיב המדויק שאליו יועתק הקובץ.
  • "הקפץ" את התפריט ובחר ב-"Paste".

3.3.5 אימות תוכן בקובצי ZIP:

בכדי לוודא שלא נוצרו שגיאות, שעלולות להפריע ואף למנוע את פתיחת הקובץ הדחוס, בתהליך הדחיסה ניתן לבצע אימות לתכולת הקובץ ווידוא שלמות התוכן.
  • בחר בקובץ ה-ZIP הרצוי.
  • "הקפץ" את התפריט על-ידי לחיצה ארוכה על הקובץ.
  • בחר ב-"Verify Archive" שנמצאת תחת "ZIP Archive".
  • הודעה תופיע על המסך באשר לתקינות הקובץ ותכולתו.

3.3.6 הוספת הערה לקובץ ZIP:

בשימוש עם קובצי ZIP רבים, לעיתים, יש צורך בהוספת הערה בנוגע לתכולת הקובץ או כל דבר אחר אשר חפץ המשתמש. ההערות מאוכסנות כחלק אינטגראלי מהקובץ ויעברו איתו במידה ויועתק או יועבר למחשב אחר.
  • בחר בקובץ ה-ZIP הרצוי.
  • "הקפץ" את התפריט על-ידי לחיצה ארוכה על הקובץ.
  • בחר ב-"Comment" שנמצאת תחת "ZIP Archive".
  • הקלד את ההערה הרצויה ואשר ע"י לחיצה על ה-"OK" בפינת המסך.
ניתן לקרוא או לשכתב הערה גם ע"י שימוש באפשרות ה"Properties", אשר בתפריט הקופץ, בלחיצה ארוכה על קובץ ה-ZIP.

3.4 חיפוש קבצים:

חיפוש הקבצים הינו אחד החלקים החשובים בכל סייר קבצים. החיפוש בסייר הקבצים של Resco מכיל, בנוסך ליכולותיו לבצע חיפוש של קובץ על-פי שם או סוג, גם את האפשרות לביצוע חיפוש קבצים המכילים קטע טקסט כלשהו. ניתן גם להגביל את החיפוש לקבצים בעלי יחוס מסוים. (Read only, Rom וכדומה)

3.4.1 ביצוע חיפוש:

  • בחר בתפריט "Edit" ובאפשרות "Find". לחילופין ניתן ללחוץ על כפתור החיפוש בסרגל ה"מתקדם".
  • הקש את שם הקובץ או השתמש בפילטור כוללני תוך שימוש בפקודות המוכרות מסייר הקבצים השולחני כגון: *.סוג הקובץ (לחיפוש קבצים מסוג מסוים) וכו'.
  • בחר בתיקיה בה ברצונך שיבוצע תהליך החיפוש.
  • לחץ על "Find".
  • הקבצים שנמצאו מתאימים יוצגו בחלקו התחתון של החלון.

3.4.2 חיפוש טקסט בקבצים:

  • בחר בתפריט "Edit" באפשרות "Find". לחילופין ניתן ללחוץ על כפתור החיפוש בסרגל ה"מתקדם".
  • הקש את שם הקובץ, בו ברצונך שיבוצע חיפוש הטקסט, או חלק ממנו.
  • לחץ על כפתור ה-"Find Text".
  • הקלד את הטקסט לחיפוש.
  • הגדר האם לבצע חיפוש של המילה בשלמותה בלבד על-ידי סימון ה-"Whole words only".
  • הגדר האם לבצע חיפוש של המילה תוך הקפדה על אותיות רישיות על-ידי סימון ה-"Case Sensitive".
  • לחץ על כפתור ה-"Find Text".
  • הקבצים שנמצאו מתאימים יוצגו בחלקו התחתון של החלון.

3.4.3 חיפוש קבצים מתקדם:

ה"חיפוש המתקדם" מאפשר חיפוש קבצים במערכת תוך שימוש בפילטרים שונים ולאו דווקא על-פי שם קובץ או חלק ממנו. החיפוש המתקדם ניתן לשימוש בשילוב עם החיפוש הרגיל ובעצם כך מצמצם את מספר התוצאות.
  • בחר בתפריט "Edit" באפשרות "Find". לחילופין ניתן ללחוץ על כפתור החיפוש בסרגל ה"מתקדם".
  • בחר בלשונית ה-"Advanced".
    • Not older than – משמש לביצוע חיפוש על-פי גילו של הקובץ במערכת. יש לסמן את תיבת הסימון ולהגדיר את גילו של הקובץ.
    • Date Between – משמש לביצוע חיפוש קובץ שנוצר ב"חלון תאריכים" מסוים. יש לסמן את תיבת הסימון ולהגדיר את "חלון הזמן" הרצוי.
    • File size – משמש לביצוע חיפוש על-פי גודלו של הקובץ. יש לסמן את תיבת הסימון ולהגדיר את גודלו המקסימאלי של הקובץ לחיפוש.
    • Attributes – משמש לביצוע חיפוש על-פי ייחוס הקובץ. יש לסמן את תיבת הסימון ולהגדיר על-פי אילו ייחוסים יבוצע החיפוש.
  • לחץ על "Find".
  • הקבצים שנמצאו מתאימים יוצגו בחלקו התחתון של החלון.

3.4.4 שימוש בקבצים שנמצאו בחיפוש:

  • בחר בקובץ על-ידי לחיצה עליו במטרה לפתחו. לחילופין ניתן ללחוץ על "Feed to Listbox" במטרה להציג את כל הקבצים בתצורת רשימה.
  • בשלב זה ניתן להשתמש בקבצים שנמצאו בדיוק באותו האופן בו ניתן להשתמש בקבצים אחרים בסייר הקבצים.

3.5 מיפוי כונן ברשת פנימית:

אפשרות מיפוי הכונן מאפשרת גישה, תוך שימוש בסייר של Resco, לתיקיות, קבצים וכוננים משותפים על מחשבים שכנים ברשת הפנימית. השימוש באפשרות זו ניתן רק במחשבי כף-יד בעלי מערכת הפעלה WM2002 ומעלה ותוך שימוש בחיבור רשת בלבד דרך BT, WIFI או חיבור קווי. חיבור דרך תוכנת ה-ActiveSync אינו מאפשר שימוש ב"מיפוי כונן" של מחשב אחר וגישה אליו.

3.5.1 מיפוי כונן:

  • צור חיבור לרשת.
  • לחץ על כפתור ה-Network ב"סרגל המתקדם".
  • בחר ב-"Map Drive".
  • המתן בזמן שהמערכת מבצעת חיפוש של מחשבים שכנים ברשת הפנימית.
  • בחר במחשב ובכונן שברצונך למפות.
  • הקש את שם המשתמש והסיסמה לחיבור לאותו המחשב. אם לא הוגדרה כזו פשוט לחץ על "אישור".
  • לחץ על כפתור ה-"Share".
  • הכונן הממופה יופיע כחלק מ"עץ הקבצים".

בשלב זה ניתן לבצע את רוב הפעולות המוכרות לנו משימוש בסייר הקבצים כאילו הכונן הממופה הינו חלק מהמערכת.

3.5.2 הסרת כונן ממופה:

  • לחץ על כפתור ה-Network ב"סרגל המתקדם".
  • בחר ב-"Unmap Drive".
  • בחר בכונן אותו ברצונך להסיר.
  • לחץ על כפתור ה-"Disconnect".

4 סל המחזור:

בדומה למחשב השולחני, סל המחזור מאכסן פריטים שנמחקו בכדי שניתן יהיה לשחזרם במקרה של מחיקה לא מכוונת או מסיבות אחרות. ככל הנראה, עקב השינוי באופי השימוש במחשבי כף-יד בקרב המשתמשים, נוצר הצורך ב"סל-מחזור" ו-Resco שילבו אותו כחלק אינטגראלי מסייר הקבצים שלהם. ניתן למצוא את סל המחזור ב"עץ הקבצים" כ"תיקיית שורש". מחיקת קבצים והעברתם אל סל המחזור אינה מפנה מקום בזיכרון עד לרגע ריקון סל המחזור.

4.1 פעולות הניתנות לביצוע:

4.1.1 שחזור פריטים שנמחקו:

  • בחר ב"סל המחזור" תחת עץ הקבצים.
  • בחר את הפריט שברצונך לשחזר.
  • "הקפץ" את התפריט על-ידי לחיצה ארוכה על הפריט הנבחר.
  • בחר ב-"Restore".
  • הקובץ ישוחזר למקומו המקורי.

4.1.2 שחזור פריטים שנמחקו למיקום שונה:

  • בחר ב"סל המחזור" תחת עץ הקבצים.
  • בחר את הפריט שברצונך לשחזר.
  • "הקפץ" את התפריט על-ידי לחיצה ארוכה על הפריט הנבחר.
  • בחר ב-"Move To".
  • בעץ הקבצים שיפתח הגדר את הנתיב אליו יועבר הקובץ.
  • הקובץ יועבר למיקום החדש.

4.1.3 ריקון סל מחזור ומחיקת פריטים לצמיתות:

  • בחר ב-"Empty Recycle Bin" תחת תפריט ה-"File".
  • אשר את פעולת הריקון.

לאחר פעולה זו לא ניתן יהיה לשחזר את הפרטים שנמחקו.

5 עורך הרג'יסטרי

עורך הרג'יסטרי מאפשר עריכת מפתחות וערכים של הרג'יסטרי, המכילים מידע אודות הגדרותיהן של תוכנות במערכת ואופי פעולתן, בצורה נוחה ופשוטה, אך עם זאת מהווה כלי חזק ושימושי בעיקר למשתמשים ה"כבדים". הרג'יסטרי, באופן נורמאלי, אינו זמין למשתמש כך שלביצוע שינויים בו יש צורך בעורך רג'יסטרי שיציג את הנתונים וידע לטפל בהם. יש לקחת בחשבון שעריכת הרג'יסטרי באופן לקוי עלולה לגרום לקריסת המערכת באופן כזה שרק "אתחול קר" (Hard Reset) יפתור.

עורך הרג'יסטרי של Resco מוצג כ"עץ קבצים" המכיל את מפתחות הרג'יסטרי ותחתיהם את ערכי הרג'יסטרי. בכדי להפעיל את "עורך הרג'יסטרי" ולצפות ב"עץ הרג'יסטרי" יש צורך לנקוט באחת משתי פעולות:
  • ב"עץ הקבצים" של סייר הקבצים ישנו חלק המוגדר כ"My Registry". במידה ואין חלק כזה יש צורך להיכנס להגדרות ה-"Add-Ins" ולאפשר את הצגת "עץ הרג'יסטרי" כחלק מסייר הקבצים. סימון האפשרות הזו, תחת הגדרות ה-"Add-Ins" אינה מומלצת לשימוש רגיל וזאת בכדי למנוע עריכת שאינה מכוונת ובכך לגרום לבעיות קשות בפוקט.
  • יש לגשת לתפריט "התחל" ולבחור ב-"תוכניות". שם ניתן לראות צלמית הרשומה כ-"Resco Registry". לחיצה עליה תפעיל אך ורק את עורך הרג'יסטרי ללא סייר ה"קבצים".

5.1 ממשק עורך הרג'יסטרי:

5.1.1 סרגל הכלים:

סרגל הכלים בתחתית המסך דומה מאוד בתפקודו ואפשרויותיו לסרגל המוצג ב"סייר הקבצים". לכן לא ארחיב עליו יתר על המידה. הסרגל מתואר כאן בסדר ההולך משמאל לימין.

5.1.1.1 תפריט ה-"File":

האפשרויות בתפריט זה זהות לאפשרויות בתפריט ה-"File" ב"סייר הקבצים" פרט לשתי האפשרויות הבאות:
  • New – משמש ליצירת מפתח או ערך רג'יסטרי חדש. ערכים חדשים יכולים להיווצר באחד מארבעה סוגים: String, Multi Line String, Binary או Dword.
  • Import – משמש ליבוא קבצי רג'יסטרי שיוצאו מבעוד מועד או ע"י עורך רג'יסטרי אחר.
יש לשים לב לכך שלכל מפתח ברג'יסטרי ישנו ערך מסוג Dword המופיע תחת השם "(Default)". ערך זה אינו בר מחיקה או שינוי שם.

5.1.1.2 תפריט ה-Edit:

זהה לחלוטין לתפריט ה-Edit בממשק של "סייר הקבצים".

5.1.1.3 תפריט ה-View:

זהה לחלוטין לתפריט ה-Edit בממשק של "סייר הקבצים".

5.1.1.4 חיפוש

החיפוש כאן, בשונה מאפשרות החיפוש ב"סייר הקבצים", מבצע חיפוש במפתחות וערכי הרג'יסטרי.

5.1.1.5 שאר הכפתורים

הינם: Up One Level – מעבר תיקיה אחת מעלה בהיררכית הקבצים. גזור, העתק, הדבק ו-מחק, אשר מתפקדים באופן זהה לתפקודם ב"סייר הקבצים".

5.1.2 התפריט ה"קופץ" על מפתח רג'יסטרי:

  • New – יצירת ערכי רג'יסטרי חדשים.
  • Export – יצוא מפתח רג'יסטרי לקובץ מסוג REG.

5.1.3 התפריט ה"קופץ" בלחיצה ארוכה על ערך ברג'יסטרי:

  • Modify – ביצוע עריכה לערך ברג'יסטרי.
  • Move to – הזזת ערך למיקום (מפתח) שונה.
  • Cut – גזירת הערך מהמיקום הנוכחי.
  • Copy – העתקת הערך.
  • Delete – מחיקת הערך.
  • Rename – שינוי שם הערך.
בניגוד למחיקת הקבצים, כאן, ערכים שנמחקו אינם מועברים ל"סל המחזור" כך ששחזורם אינו אפשרי. לכן, לפני שינויים ברג'יסטרי מומלץ לבצע גיבוי של כל הרג'יסטרי או של המפתחות ששונו וזאת על-מנת שיהיה אפשר לשחזרו בעת הצורך. קיימת אף עדיפות לביצוע גיבוי מלא של המכשיר על-ידי תכנת גיבוי.

5.1.4 התפריט ה"קופץ" בלחיצה ארוכה על "My Registry":

  • Import – יבוא קובץ רג'יסטרי מסוג REG.
  • Export – יצוא כל הרג'יסטרי לקובץ מסוג REG.

5.2 פעולות הניתנות לביצוע באמצעות עורך הרג'יסטרי:

5.2.1 יצירת מפתח רג'יסטרי חדש:

  • גש למיקום בו הינך רוצה ליצור מפתח רג'יסטרי חדש.
  • לחץ על תפריט "File".
  • בחר ב-"New" ו-"Key".
  • הקלד את שם המפתח ולחץ על "Done" בתחתית החלון.

5.2.2 יצירת ערך רג'יסטרי חדש:

  • גש למפתח הרג'יסטרי בו הינך מבקש ליצור ערך חדש.
  • לחץ על תפריט ה-"File".
  • בחר ב-"New".
  • בחר בסוג הערך אותו ברצונך ליצור. ניתן לבחור אחד מבין ארבעה סוגי ערכים: String, Multi Line String, Binary או Dword.
  • הקלד את הנתונים הרצויים ולחץ על "Done" בתחתית החלון.

5.2.3 ייצוא מפתחות וערכי רג'יסטרי:

  • בחר בערך או במפתח הרג'יסטרי אותו הינך מבקש לייצא.
  • "הקפץ" את התפריט על-ידי לחיצה ארוכה הערך או המפתח המבוקש.
  • בחר ב-"Export".
  • הקלד שם לקובץ הרג'יסטרי המיוצא.
  • הגדר את התיקייה אליה ייוצא הקובץ. במידה והינך רוצה ליצור תיקיה חדשה יש ללחוץ על ה-"New Folder".
  • לחץ על "Save".
בסרגל התחתון קיים כפתור המשנה את אופן חיפוש התיקייה בה ישמר הקובץ המיוצא. הכפתור משנה את הממשק בין תצוגה של "עץ קבצים" לתצוגה הדומה לסייר הקבצים המובנה, אשר מציג את התיקיות הקיימות המכשיר.

5.2.4 ייבוא ערכי רג'יסטרי מקובץ במכשיר:

  • לחץ על תפריט ה-"File".
  • בחר ב-"Import".
  • הגדר את המיקום בו הקובץ נמצא.
  • בחר את הקובץ מהרשימה שתופיע.

5.2.5 יבוא ערכי רג'יסטרי ממכשיר אחר באמצעות IR:

  • לחץ על תפריט ה-"File".
  • בחר ב-"Import".
  • בסרגל התחתון, לחץ על IrDA.
  • הצב את עיניות ה-IR של שני המכשירים אחת מול השנייה.
  • בצע "שידור" באמצעות IR ("במבום") של קובץ הרג'יסטרי מהמכשיר השני.
  • המתן לקבלת הקובץ.

5.2.6 ייבוא ערכי רג'יסטרי המאוכסן על גבי כונן במחשב "שכן" ברשת פנימית (כונן ממופה):

  • לחץ על תפריט ה-"File".
  • בחר ב-"Import".
  • בסרגל התחתון, לחץ על כפתור ה-"Network".
  • בחר ב-"Map Drive"
  • מפה את הכונן שבו מאוכסן קובץ הרג'יסטרי. (ראה "מיפוי כונן".... סעיף....)
  • בחר את הקובץ ויבא אותו.

6 התוסף למסך ה-Today:


התוסף של Resco מציג מספר דברים מגוון ומאפשר גישה ישירה ונוחה לחלקים שונים, אך חשובים, במערכת ההפעלה של הפוקט. התוסף מוצג כברירת מחדל מיד לאחר התקנת התוכנה אך על-פי העדפתו של המשתמש יש אפשרות למנוע את הצגתו. על מסך ה-Today יוצג מצבם של כל אזורי הזיכרון במכשיר, מצב הסוללה וקיצורי דרך לתוכנות, קבצים או תיקיות. תחת תיקיית התוכניות תתווסף תוכנה חדשה בשם "System Info" אשר מאפשרת, גם היא, את הצגת מצב הזיכרון והסוללה.

6.1 הגדרות ואפשרויות השימוש בתוסף:

בכדי להיכנס למסך ההגדרות יש צורך ללחוץ על הצלמית הסמוכה לצידו השמאלי של התוסף. מסך ההגדרות מציג את אפשרויות תצוגת התוסף בארבעה חלקים עיקריים:
  • Skin – בחירת העיצוב וצורות הצלמיות של התוסף.
  • Show Battery Status – הצגת מצב הסוללה וההגדרות הכרוכות בה.
  • Show Memory and Storage – הצגת אזורי אכסון וזיכרון וההגדרות הכרוכות בהם.
  • Show Application & Documents – הצגת קיצורי דרך וההגדרות הכרוכות בהם.

6.1.1 Skin:

העיצוב ניתן לשינוי בין שני מצבים כאשר הראשון הוא ברירת המחדל והשני "Compact". ניתן להוריד מהאתר של Resco עיצובים נוספים לתוסף. וזאת על-ידי לחיצה על "Get More Skins" בתחתית המסך. תוצג הרשימה של העיצובים הזמינים להתקנה. יש צורך לסמן את תיבת הסימון הסמוכה לשם העיצוב וללחוץ על "Install" בתחתית המסך. ליציאה יש ללחוץ על "Close".

6.1.2 Show Battery Status:

סימון תיבת הסימון תאפשר את הצגת מצב הסוללה בתוסף. ניתן להציג את מצבה של הסוללה הראשית ו\או של סוללת הגיבוי בהנחה שיש כזו במכשיר. זאת בהתאם להגדרות הניתנות לשינוי בסעיף "Change Items" הסמוך לתיבת הסימון.
  • Show Main Battery – תאפשר את הצגת הסוללה הראשית.
  • Show Backup Battery – תאפשר את הצגת סוללת הגיבוי.

6.1.3 Show Memory and Storage:

סימון תיבת הסימון תאפשר את תצוגת קיבולתם של אזורי הזיכרון השונים (כרטיס זיכרון, RAM, זיכרון הפלאש) בהתאם להגדרות הניתנות לשינוי בסעיף "Change Items" הסמוך לתיבת הסימון.
  • Default Display Mode – הנתון הסמוך לצלמית מאפשר יציג, בהתאם להעדפת המשתמש, את אחד מהדברים הבאים:
    • מקום אכסון פנוי באזור הזיכרון המוצג.
    • הצגת הנפח שבשימוש באזור הזיכרון המוצג.
    • הצגת נפחו הכולל של אזור הזיכרון המוצג.
    • תצוגת אחוזים.
  • Default Action – לחיצה על צלמית תניב את אחת מהפעולות הבאות:
    • Open Storage Folder – הצגת תכולתו של תא הזיכרון תוך שימוש בסייר הקבצים.
    • Show Properties – הצגת ה"מאפיינים" של אותו אזור זיכרון.

6.1.4 Show Application & Documents:

סימון תיבת הסימון תאפשר את הצגת קיצורי הדרך לתוכניות, מסמכים ואף תיקיות כחלק מהתוסף. הדבר נועד לאפשר גישה מהירה לקבצים או יישומים בהם השימוש נעשה לעיתים תכופות. לחיצה על "Change Items" תוביל למסך בו ניתן להגדיר לאילו קבצים, תוכנות ותיקיות יהיו קיצורי דרך בתוסף.
  • הוספת קיצור דרך:
    • לחץ על תפריט ה-"ADD".
    • בחר בסוג הקובץ לו הינך מעוניין ליצור קיצור דרך:
      • Application – יישום.
      • Document – מסמך או קובץ אחר.
      • Folder – תיקיה.
      • Separator – הוספת רווח בין קבוצות קיצורי הדרך.
    • בעזרת מערכת הסיור שתופיע, נתב אל הקובץ, התיקייה או היישום המבוקש ובחר בו.
    • הקובץ יתווסף לרשימת הקיצורים הקיימים.
  • הסרת קיצור דרך:
    • בחר בפריט המיועד למחיקה מרשימת הקיצורים הקיימים.
    • "הקפץ" את התפריט על-ידי לחיצה ארוכה על הפריט המיועד למחיקה.
    • בחר ב-"Delete".
  • שינוי הסדר של קיצורי הדרך:
    • בחר בפריט אותו ברצונך להזיז.
    • בתפריט ה-"Edit" בחר באפשרות המתאימה:
      • להזזה מעלה בחר ב-"Move UP".
      • להזזה מטה בחר ב-"Move Down".

7 "לקוח" ה-FTP

FTP (File Transfer Protocol) הינו פרוטוקול המשמש להעברת קבצים בין מחשבים, המרוחקים זה מזה, תוך שימוש בתקשורת אינטרנטית. במחשבים מסוימים כמו גם שרתים מותקנת תוכנת "שרת FTP" המהווה את ה"חצי השני" לתוכנת ה"לקוח". תוכנת הלקוח מאפשרת גישה לשרת ה-FTP, הורדת קבצים ממנו אל הפוקט, העלאת קבצים מהפוקט אליו, עריכת שמות הקבצים על השרת וצפייה בקבצים בפורמטים הנתמכים ע"י הסייר של Resco. ניתן לראות את חלקו של "לקוח ה-FTP" כחלק מ"עץ הקבצים". במידה ואינו מוצג יש צורך לגשת ל"הגדרות" ה-"Add-Ins" ולאפשר את הצגתו.

7.1 חיבור לשרת

7.1.1 יצירת חיבור לשרת:

"הקפץ" את התפריט על-ידי לחיצה ארוכה על "My FTP Locations" שב"עץ הקבצים".
בחר ב-"New FTP Session". לחילופין לחץ על תפריט ה-"File" ובחר ב-"New FTP Session".

בחלון שיפתח יש צורך להגדיר את הדברים הבאים:
  • Session – תן שם לחיבור הזה. הזן טקסט חופשי לבחירתך.
  • Host – הקלד את כתובת ה-IP או כתובת ה-DNS, של שרת ה-FTP.
  • Port – הגדר את הפורט בו השרת משתמש.
  • Login – הקלד שם משתמש לגישה לשרת. והשרת אינו דורש שם משתמש יש אפשרות להשאיר תיבת טקסט זו ריקה ולסמן את האפשרות "Anonymous".
  • Password – הקלד סיסמה לגישה לשרת.
  • Local Dir – כאן יש להגדיר את תיקיית ברירת המחדל לשמירה של קבצים שיורדו מהשרת.
  • Remote Dir – הגדרת "תיקיית האם" אשר חיבור ה-FTP מתייחס אליו. תיקיות אחרות שאינן נמצאות תחת תיקייה זו, בהיררכיית הקבצים, לא יוצגו.
  • Passive Mode – יש לסמן תיבת סימון זו כאשר ישנן בעיות בחיבור. הדבר משמש בעיקר לחיבור דרך ActiveSync, או כאשר החיבור לרשת הינו מורכב.
  • לחץ על "OK"
  • החיבור יופיע תחת "My FTP Locations"

7.1.2 התחברות:

  • "הקפץ" את התפריט על-ידי לחיצה ארוכה על החיבור המבוקש.
  • בחר ב-"Connect".
  • יוצג דיאלוג החיבור בין ה"שרת" ל"לקוח" ולאחר חיבור מוצלח יוצגו התיקיות שעל השרת כחלק מעץ הקבצים.

7.1.3 שינוי הגדרות החיבור:

  • "הקפץ" את התפריט על-ידי לחיצה ארוכה על החיבור המבוקש.
  • בחר ב-"Properties".
  • שנה את ההגדרות, בהתאם לדרישות, ולחץ על "OK".

7.2 פעולות הניתנות לביצוע:

יש לשים לב לכך שחלק מהפעולות המתוארות כאן לא תהיינה ברות ביצוע עקב הגבלת השרת.

7.2.1 הורדת קובץ מהשרת אל מכשיר הפוקט:

  • צור חיבור לשרת.
  • סייר אל עבר הקובץ אותו ברצונך להוריד.
  • "הקפץ" את התפריט על-ידי לחיצה ארוכה על הקובץ הנבחר ובחר באחת מהאפשרויות הבאות:
    • Download – הורדת הקובץ ישירות לתיקיית ברירת המחדל שהוגדרה בשלב הגדרת החיבור כ-"Local Dir".
    • Download To – הורדת הקובץ לתיקיה שאינה ברירת המחדל תוך שימוש בסייר לבחירת תיקיית היעד. בשימוש באפשרות זו יש אפשרות גם לחריגה מהגדרות ברירת המחדל בכל הנוגע להורדות. לחץ על "Download".

7.2.2 העלאת קובץ ממכשיר הפוקט אל השרת:

  • צור חיבור לשרת.
  • סייר, בעזרת סייר הקבצים, לקובץ אותו ברצונך להעלות לשרת.
  • "הקפץ" את התפריט על-ידי לחיצה ארוכה על הקובץ הנבחר ובחר באחת מהאפשרויות הבאות:
    • Cut – אם בכוונתך להעביר את הקובץ לשרת. הקובץ לא יישאר על הפוקט.
    • Copy – אם בכוונתך להעתיק את הקובץ לשרת. העק של הקובץ יישאר על הפוקט.
  • סייר, בעזרת סייר הקבצים, אל המיקום בשרת אליו ברצונך להעלות את הקובץ.
  • "הקפץ" את התפריט על-ידי לחיצה ארוכה על תיקיית היעד ובחר ב-"Paste".

7.2.3 צפייה בקובץ הנמצא בשרת:

  • צור חיבור לשרת.
  • סייר אל עבר הקובץ בו ברצונך לצפות בעזרת התוכנה המובנית.
  • "הקפץ" את התפריט על-ידי לחיצה ארוכה על הקובץ הנבחר ובחר ב-"View".
לשם הצפייה, יורד הקובץ אל המכשיר באופן זמני, כך שבעת סגירת תוכנת הצפייה הקובץ יימחק.

7.2.4 שינוי שם קובץ על השרת:

  • צור חיבור לשרת.
  • סייר אל עבר הקובץ אשר את שמו ברצונך לשנות.
  • "הקפץ" את התפריט על-ידי לחיצה ארוכה על הקובץ הנבחר ובחר ב-"Rename".
  • הקלד את הם החדש ולחץ על מקש ה-Enter במקלדת הוירטואלית.

7.2.5 מחיקת קובץ מהשרת:

  • צור חיבור לשרת.
  • סייר אל עבר הקובץ אותו ברצונך למחוק.
  • "הקפץ" את התפריט על-ידי לחיצה ארוכה על הקובץ הנבחר ובחר ב-"Delete".
  • עקוב אחר ההוראות ואשר את המחיקה.

8 החלק הדסקטופי:

כחלק מתהליך ההתקנה, בהנחה שסימון תיבת הסימון לא הוסר, מותקנים למחשב הנייח שני תוספים המקנים עבודה קלה יותר עם קבצים המועברים בינו לבין מחשב כף-היד. לתפריט ה"קופץ" על קובץ או תיקיה במחשב הנייח תתווספנה שתי אפשרויות נוספות:
  • Send To - שליחת קובץ בצורה באופן קל יותר אל תיקיה מסוימת?בפוקט.
  • Encryption - תמיכה בהצפנה ופענוח קבצים בקידודים התואמים את הקידודים שבסייר של Resco.

8.1 פעולות הניתנות לביצוע:

הפעולות מבוצעות על מחשב ה-PC ודורשת סנכרון פעיל על מנת לבצען.

8.1.1 שליחת קובץ ממחשב ה-PC לתיקייה ספציפית בפוקט:

  • בחר קובץ להעברה והקלק עליו באמצעות המקש הימני בעכבר.
  • בחר באפשרות "Send To".
  • בחר ב-"My Device".
  • ב"עץ הקבצים"?שיפתח מוצגות התיקיות ממחשב כף-היד. בחר את הנתיב הרצוי ולחץ "End".
  • הקובץ יועתק למכשיר.

8.1.2 הצפנת קבצים בפורמט תואם לסייר של Resco.

  • בחר קובץ להצפנה והקלק עליו באמצעות המקש הימני בעכבר.
  • בחר ב-"Resco Crypting".
  • בחר ב-"Encrypt".
  • הקלד את הסיסמה.
  • הקלד סיסמה בשנית למטרת אימות.
  • בחר האם למחוק את הקובץ המקורי ע"י סימון תיבת הסימון.
  • תחת סעיף ה-"Settings" ניתן להגדיר את העדפות ההצפנה בדומה להגדרות על גבי הפוקט.

8.1.3 פענוח קבצים מקודדים בפורמט תואם לסייר של Resco.

  • בחר קובץ לפענוח והקלק עליו באמצעות המקש הימני בעכבר.
  • בחר ב-"Resco Crypting".
  • בחר ב-"Decrypt".
  • הקלד סיסמה לפתיחה.
  • בחר האם למחוק את הקובץ המקורי ע"י סימון תיבת הסימון.
  • לחץ על "Decrypt".

9 הגדרות:

מערכת ההגדרות של התוכנה מאפשרת למשתמש להגדיר את הסייר על תוספיו, לשימוש אופטימאלי. בכדי להיכנס למערכת ההגדרות יש ללחוץ על תפריט ה-"FILE", המופיע בחלקו השמאלי תחתון של המסך, ו-"OPTIONS". מערכת ההגדרות מחולקת לכרטיסיות אשר בכל אחת ניתן להגדיר חלק כזה או אחר מכלל התוכנה. שחזור להגדרות ברירת המחדל יבוצע ע"י לחיצה על "Set Defaults" בתחתית מערכת ההגדרות.

9.1 General Options:

הכרטיסייה הראשונה במסך ההגדרות מתייחסת להגדרות הכלליות בתוכנה כגון הגדרות פונט והתנהגות כללית של התוכנה.
  • "Remember last opened folder" – סימון תיבה זו יביא למצב בו התוכנה "תזכור" את התיקייה האחרונה שנצפתה ותחזור אליה בעת הפעלה מחודשת.
  • "Open folder shortcuts with Resco Explorer" – פתיחת קיצורי דרך יבוצע, כברירת מחדל, תוך שימוש בסייר הקבצים של Resco.
  • "Double Tap Activation" – כאשר תיבה זו מסומנת, הפעלת קובץ בסייר תבוצע על-ידי "לחיצה כפולה" ולא בלחיצה בודדת.
  • "Use IrDA Via OBEX" – OBEX הינה שיטה מתקדמת ונוחה יותר להעברת קבצים תוך שימוש ב-IR (אינפרא אדום). השימוש בשיטה זו מומלץ ונח יותר אך למרות זאת, לעיתים, עלולות להתגלות בעיות בהעברת קבצים מול מכשירים מסוימים אשר אינם תומכים בתקן, או אז יש להסיר את הסימון מהתיבה ולנסות בשנית.

9.1.1 הגדרות גופן:

  • "Font Size" – גודל הגופן בתוכנה ניתן לשינוי לאחד מתוך ארבעה מצבים: קטן, נורמאלי, גדול או גדול במיוחד.
  • "Bold" – סימון תיבה זו יביא לשימוש בגופן מעובה.
  • "ClearType" – סימון התיבה יביא לשימוש בגופנים בתצוגת ClearType אשר מיועדת לצפייה "נקייה" יותר במסכי LCD.

9.2 Add-Ins:

9.2.1 כיצד יוצג כונן ברשת הפנימית:

ניתן להגדיר את אופן הצגת "כונן ממופה" הנמצא ברשת פנימית, בסייר הקבצים לאחת משתי האפשרויות הבאות:
  • as "My Network" Root - הכונן הממופה יוצג בעץ הקבצים כתיקיה ראשית בעץ הקבצים תחת השם "MyNetwork".
  • As "Network" Folder under "MyDevice" – הכונן הממופה יוצג כ"תיקיה" תחת "MyDevice".

9.2.2 תוספים פעילים:

ניתן למנוע או לאפשר את שימוש התוספים שבסייר.
  • Internal ZIP Compression – תמיכה מובנית של סייר הקבצים בכיווץ ופרישה של קבצי ZIP.
  • My FTP Locations – שימוש בסייר הקבצים כתוכנת "לקוח" FTP. סימון התיבה יביא לתוספת של תיקיה ראשית בשם " My FTP Locations" בעץ הקבצים.
  • My Registry - שימוש בסייר הקבצים לטובת עריכת הרג'יסטרי. סימון התיבה יביא לתוספת של תיקיה ראשית בשם "MyRegistry" בעץ הקבצים.

9.2.3 כפתור ה-"File Associations"

ניתן להגדיר אילו סוגי קבצים ישויכו ויטופלו על-ידי הסייר ואילו סוגים יושארו לטיפול של תוכנות אחרות.
  • RXF – תמיכה וזיהוי של קבצים מוצפנים (ראה הצפנה...סעיף לא ידוע)
  • REG – תמיכה וזיהוי קבצי רג'יסטרי.
  • ZIP – תמיכה וזיהוי בקבצים המכווצים בפורמט ZIP.

9.3 Browser Options:

ניתן לבחור אחת משתי האפשרויות הבאות בשילוב סימון או אי סימון של תיבת הסימון תחתן.
  • Show All Files – אפשרות זו תציג את כל הקבצים כולל קבצי מערכת, קבצים נסתרים וכו'.
  • Hide hidden files and files with the following extensions: .DLL, .CPL, .DRV, .HTP – המנע מהצגת קבצים נסתרים, קבצי מערכת וקבצים עם הסיומות הבאות: .DLL, .CPL, .DRV, .HTP
  • Hide Files in ROM – סימון תיבה זו ימנע הצגה של קבצים המשויכים ל-ROM (מערכת ההפעלה המובנית).


9.3.1 תצוגת הקבצים:

  • Hide file extensions - יש לסמן תיבה זו למצב שבו אין אנו רוצים שהסייר יציג את סיומות הקבצים כגון, JPG, PLT וכדומה.
  • Hide folders - יש לסמן תיבה זו למצב שבו אנו רוצים שהסייר יציג, בתוכן התיקיות, קבצים בלבד ולא את תת התיקיות הנוספות. הגישה לתת התיקיות תבוצע דרך "עץ הקבצים" בלבד.
  • Use vertical window splitter - חלוקה אנכית, במקום אופקית, של המסך בין "עץ הקבצים" לבין תוכן התיקייה שנבחרה בו. (אולי צילום???)
  • Full row selection – בתצוגת "רשימה" (List) בחירת קובץ, בעת הקשה עליו, תציג סימון בחירה כחול על כל העמודות. הסרת הסימון מאפשרות זו יביא להצגת סימון כחול, בעת בחירת קובץ, רק על שם הקובץ.

9.4 Viewer Options:

9.4.1 File Viewer:

סייר הקבצים של רסקו מכיל, בין כל יכולותיו, גם את היכולת להציג קבצים באופן טקסטואלי תוך שימוש בכמה צורות קידוד: ANSI, Unicode, Binary ו-HEX. כמובן שהדבר מיועד בעיקר למשתמשים מנוסים מאוד ומתכנתים אך בהחלט מהווה כלי המקנה לסייר הקבצים הזה חשיבות נוספת.

לשם הצגת קבצים באופן טקסטואלי ניתן לבחור באחת מבין שתי אפשרויות:
  • Use internal file viewer – שימוש בתוכנת הצפייה המובנית.
  • Use external file viewer – שימוש בתוכנת צפייה חיצונית אשר תוגדר ע"י המשתמש בשורה שמתחת. בכדי להגדיר את תכנת הצד השלישי לפתיחה יש ללחוץ על כפתור ה"…" ולנווט אל קובץ ההפעלה של אותה התוכנה.





9.4.2 Use Tap to:

ניתן להגדיר לסייר כיצד יתנהג בעת לחיצה על קובץ באחד משני האופנים הבאים:
  • View selected file – הקובץ יפתח באופן טקסטואלי בהתאם למה שהוגדר בסעיפים ב-"File Viewer” שמעל.
  • Open selected file – הקובץ יפתח בהתאם לתוכנה המשויכת אליו. במידה ואין תוכנה שכזו יתבקש המשתמש לבחור תוכנה שכזו בטרם פתיחת הקובץ. הדבר דומה ל-"Open With" המוכר לנו מעולם ה-PC.
    • Use “OpenDoc” association path – פתיחת מסמכים, שנוצרו על פוקט שמריץ מערכת הפעלה 2002, עלולה להיות בעיתית על מערכת הפעלה חדשה יותר. במקרה זה יש לסמן את תיבת הסימון.

9.5 File Options:

9.5.1 Get Confirmation Before

כאן ניתן להגדיר באילו מצבים תופיע הודעה אוטומטית לאישור הפעולה הנעשית בקובץ אחד או יותר. סימון תיבת הסימון הסמוכה להגדרה תגרור הקפצת הודעה בהתאם להגדרתה.
  • Overwrite files - כאשר מבוצע ניסיון לשכתוב קובץ קיים.
  • Deleting files - במחיקת קובץ.
  • Deleting/Overwriting read-only files - במחיקה או שכתוב של קבצים המוגדרים לקריאה בלבד.
  • Deleting non-empty folders - במחיקת תיקיות המכילות קבצים.

9.5.2 Send To operation will:

הגדרות אלו נוגעות להתנהגות הסייר בעת משלוח קובץ ליעד ספציפי במכשיר תוך שימוש ב"שלח אל". ניתן לבחור אחת מתוך שתי האפשרויות:
  • Copy File(s) – העתקת הקובץ הנשלח אל תיקיית היעד, עותק ישמר בתיקיית המקור.
  • Move File(s) – העברת הקובץ הנשלח אל תיקיית היעד, לא ישמר עותק בתיקיית המקור.

9.6 ZIP Compression:

הגדרות אלו נוגעות בדרך ברירת המחדל בה יבוצע הכיווץ לפורמט ZIP. ניתן לשנות את ההגדרות, בנקל, בחלון ההגדרות שצץ בכל פעם שמבוצע כיווץ.

9.6.1 Update Mode:

הגדרות אלו נוגעות לאופי פעולתו של הסייר בעת כיווץ קבצים לתוך קובץ ZIP קיים.
  • Add and Replace - הקבצים החדשים יוספו לקובץ ה-ZIP כך שקבצים קודמים לא יעברו שינוי וגם הם יישארו בקובץ ה-ZIP המקורי.
  • Freshen Existing - רק קבצים בעלי שמות זהים הנמצאים כבר בקובץ ה-ZIP יעודכנו בהתאם לחדשים. קבצים עם שמות חדשים לא יכנסו ל-ZIP ותצוץ הודעת שגיאה המתריעה על כך.
  • Move to Archive - הקבצים שנבחרו יועבר לקובץ ZIP כך שלא יישאר עותק שלהם בתיקיית המקור.
  • Update and Add - קבצים בעלי שמות זהים יעודכנו בהתאם לחדשים תחת אותו השם, קבצים בעלי שמות שונים יתווספו לקובץ ה-ZIP.

9.6.2 Level:

רמת הדחיסה ניתנת לשינוי אך יש לזכור שזמן הכיווץ יהיה ביחס הפוך לגודל הקובץ המוגמר.
  • Best Compression - דחיסה ברמה גבוהה. הקבצים הנוצרים יהיו קטנים יחסית אך התהליך ידרוש זמן ארוך יחסית.
  • Normal Compression – דחיסה נורמאלית. דחיסה השומרת על יחס של זמן ואיכות באופן סביר.
  • Fast Compression – דחיסה מהירה. קצב הדחיסה יהיה מהיר יחסית אך הקובץ המוגמר יהיה גדול ביחס לדחיסות איטיות יותר.
  • Extra Fast Compression – דחיסה מהירה מאוד שבאה על חשבון גודל בצורה קיצונית יותר.
  • Let it uncompressed – ללא דחיסה. הקבצים שנבחרו יועברו לקובץ ZIP אך לא ידחסו. הדבר שימושי כאשר לא רוצים לפגוע באיכות הקובץ או לחילופין להגן עליו בסיסמה ולא בשימוש אפשרות ההצפנה. (ראה עמוד!!!!!)
  • Verify integrity after archive modification – ביצוע בדיקת שלמות הקובץ ותקינותו לאחר הדחיסה או השינוי שבוצע בו. יש לזכור שתהליך זה ידרוש זמן.

9.7 ZIP Extraction:

9.7.1 הגדרות לפרישת קבצים מפורמט ZIP.

  • Use folder names – כאשר תיבה זו מסומנת יפרשו הקבצים תוך שמירה על מבנה תיקיות המקור שנדחסו לקובץ. הסרת הסימון תביא לפרישת כל הקבצים לתיקיה אחת.
  • Use ANSI code – אופציה זו מיועדת לשימוש כאשר מתגלות בעיות ושיבושים בשמות הקבצים, הנפרשים, בשפה שאיננה אנגלית. אופציה זו תבוא לידי ביטוי רק כאשר השפה בה נכתבו שמות הקבצים תואמת את השפה ב"הגדרות האזוריות" (Regional Settings) שב"הגדרות" המכשיר.

9.7.2 Overwrite Mode:

במידה וכבר קיימת תיקייה בשם אליו אנחנו עומדים לפרוש קובץ מכווץ ניתן להגדיר לסייר לבצע אחת מהאפשרויות הבאות:
  • Prompt to overwrite – התוכנה תעלה שאילתה בבקשת אישור לשכתוב התיקייה הקיימת.
  • Overwrite only newer – התוכנה תבצע שכתוב של הקבצים החדשים בלבד.
  • Overwrite all files – שכתוב כל הקבצים. הדבר יביא למחיקת הקבצים בתיקיה הותיקה ופרישה של הקבצים החדשים לתוכה. (לבדוק נכונות)
  • Never overwrite – לא יבוצע שכתוב.

9.8 Recycle Bin:

כאן ניתן למצוא מספר הגדרות הקשורות לסל המחזור.
  • Do not move files to Recycle Bin. Move files immediately when deleted - סימון התיבה ימנע מהקבצים שנמחקו לעבור לסל המחזור ובעצם כך למבצע מחיקה ללא יכולת שחזור מסל המחזור.
  • Maximum size of Recycle Bin – קביעת גודל סל המחזור כחלק יחסי של כל אזור אכסון בנפרד. כך שבעצם כל אזור אכסון, כרטיס זיכרון או זיכרון פנימי, יכיל את הקבצים שנמחקו בתיקיה מיוחדת עד אשר יבוצע ריקון סל המחזור.
  • Empty Recycle Bin – לחיצה על כפתור זה תבצע ריקון של סל המחזור בכל אזורי הזיכרון. פעולה זו ניתנת לביצוע גם ללא כניסה להגדרות, ע"י לחיצה ארוכה על סל המחזור ובחירה באפשרות המתאימה.

9.9 FTP Options:

הגדרות תוסף ה"לקוח" בפרוטוקול FTP.

9.9.1 Default Action:

ההגדרות תחת סעיף זה קובעות איזו פעולה תבוצע, כברירת מחדל, כאשר נעשה ניסיון הורדה, העתקה או הדבקה של קובץ הקיים כבר במערכת הפוקט. ניתן לבחור אחת מארבע דרכי פעולה.
  • Prompt For Action – הודעה תעלה באופן אוטומטי ובה המשתמש יתבקש להגדיר מה תהיה דרך הפעולה במקרה של כל בעיה.
  • Overwrite Existing – שכתוב אוטומטי של הקובץ הישן ודריסתו ע"י הקובץ החדש.
  • Resume if possible – "לקוח" ה-FTP ינסה לחדש הורדת קובץ, שלא ירד בשלמותו לתיקיית ההורדות, באופן אוטומטי.
  • Skip existing – "לקוח" ה-FTP ימנע מהורדה מחודשת של קבצים הנמצאים, מבעוד מועד, בתיקיית היעד.

9.9.2 Incomplete Download:

תפריט זה ישמש על-מנת להגדיר מה יעלה בגורלם של קבצים אשר לקוח ה-FTP לא הוריד בשלמותם עקב בעיות תקשורת או הפרעה ע"י המשתמש.
  • Leave incomplete downloads - קבצים שלא הורדו בשלמותם יישארו במערכת.
  • Delete incomplete downloads - קבצים שלא הורדו במלואם ימחקו מהמערכת.
  • Try to reconnect and resume file - המערכת תזהה באופן אוטומטי את ניתוק התקשורת ותנסה לבצע חיבור מחדש ובמידת האפשר תמשיך להוריד את הקובץ.

9.9.3 Transfer Type:

העברת קבצים בפרוטוקול FTP מתבצעת בכמה שיטות. האחת ASCII והשנייה Binary. הבחירה בשיטת ההעברה תלויה בסוג הקובץ המועבר. כברירת מחדל התוכנה מוגדרת למצב Auto בו סוג הקובץ ושיטת ההעברה מזוהות באופן אוטומטי, אך ניתן גם להגדיר באופן ידני את שיטת ההעברה לאחת מהשתיים, Binary או ASCII.

9.10 Registry Options:

9.10.1 Get Confirmation Before:

הגדרת עורך הרג'יסטרי לבקשת אישור פעולה בהתאם לסוגה. סימון תיבת הסימון יביא להודעה בעת ביצוע הפעולה המוגדרת.
  • Overwriting keys/values - בעת שכתוב של ערך או מפתח רג'יסטרי.
  • Deleting keys/values - בעת מחיקת ערך או מפתח רג'יסטרי.
  • Deleting non-empty keys - בעת מחיקת מפתח או ערך רג'יסטרי שאינו ריק.
  • Prompt modifications - לאחר צפייה בערך רג'יסטרי ולחיצה על "OK" תבוא הודעה לפני סגירת הקובץ גם אם לא בוצע בו כל שינוי.

9.10.2 List View Settings:

הגדרות צפייה בערכי הרג'יסטרי ו"עץ" מפתחותיו. ניתן להציג את מפתחות הרג'יסטרי כתיקיות ב"עץ" הרג'יסטרי ע"י סימון תיבת ה-"Show keys". אי סימון התיבה יביא לתצוגת המפתחות כ"קבצים".

10 דברי סיום:

כולי תקווה כי המדריך יימצא שימושי, עוזר ומכוון. במידה ונתקלתם במידע שאינו ברור, שגוי או שיש לכם הערות אשמח לקבלן ולעדכן את המדריך בהתאם.
 
19-Jan-2006